Business Hours

Monday – Saturday
6 AM – 6 PM PDT
Local: 2:45 AM

Sign in

  1. Forgot your password?

Libronix for Mac and OSX Lion/Safari 5

Libronix for Mac and OSX Lion/Safari 5


Libronix for Mac is incompatible with OSX 10.7 (Lion) and versions of OSX Safari 5.0.6 or higher.

To continue enjoying your Libronix software on Lion and Safari 5 visit our Logos Upgrade page to get the latest version of Logos 4 or contact one of our sales representatives at (800)875-6467.


For more information about Logos 4 and OSX Lion visit our Logos 4 Mac forums.

Last Updated: 4/23/2012