Faithlife Corporation

Business Hours

Monday – Saturday
6 AM – 6 PM PDT
Local: 12:30 PM

Update to Libronix DLS 3.0b

Click the update button to run Libronix Update, which will download and install the components necessary to update your system to version 3.0b.

About this update

Libronix Digital Library System 3.0b can be downloaded and installed via the Internet. This update will give you the latest Libronix DLS engine, rebuilt Bibles, and new versions of the automation addin modules you already own. It will not unlock any new books or addin modules.

  • This update is required for anyone running Internet Explorer 7. For details, visit IE7 and Libronix DLS.
  • Even if you're not currently running Internet Explorer 7, we encourage you to update to Libronix DLS 3.0b.

Why is this update called a "Beta"?

Please be assured that, despite the "Beta" label, the majority of the code in Libronix DLS 3.0b Release Candidate 2 has been well-tested and is identical to 3.0a which has been shipping on disc since late September.

Unlike most beta releases, we will provide support for Libronix DLS 3.0b Release Candidate 2.

Libronix DLS 3.0b was created to deliver emergency code changes needed to fix a display bug caused by the release version of Internet Explorer 7.
For the small number of people who have already installed IE7 and are encountering problems with Libronix DLS, updating to version 3.0b is the only way to fix those problems, so we chose to release it as soon as possible.

Please note: The minimum system requirements for Libronix DLS have changed as of version 3.0.

Click the button above to run Libronix Update, which will download and install the components necessary to update your system to version 3.0b.

Important Links

  • Important! Please Read This First!
  • IE7 and Libronix DLS.
  • System requirements
  • Updating Libronix DLS from a Zip File
  • Instructions for uninstalling IE7